Skip to end of metadata
Go to start of metadata

Before adding new entries to the Change Log, please see the Legend and Format Guide.

  • Version 1.1.0 (July 10, 2017)

    • (plus) [ JENKINS-39985 ] Added support for context Alert Filters.
    • (plus) [ JENKINS-43554 ] Added support for the internationalization of:
      1. UI Elements
      2. Associated Help Doc's
    • (warning) [ JENKINS-43483 ] Added support to the authentication module to be able to utilize Logged Out Indicators.
    • (minus) [ JENKINS-43384 ] Removed support from the ZAP Settings Variable for System Environment Variables, Build Variables as well as Environment Inject Plugin Variables since the Job Configuration page is ONLY run on the master and has no access to the slave.
    • (error) Bug-fixes:
      1. Fixed Broken links in Help Files
      2. Fixed misused variables (evaluatedSessionFilename instead of evaluatedZapSettingsDir) of ZAPDriver.java
      3. Correct improper use of JIRA Extension parameters.
    • (info) Usability Improvements:
      • Updated all affected help files
      • Created the webapp folder
      • Established clearer distinction between the ZAP Installation Directory and ZAP Home Directory
    • (info) Updated LICENSE and README information.

  • Version 1.0.8 (Mar 19, 2017)

    • (warning) Changed the default authentication script directory for the plugin to match the directory for ZAP (GUI) and updated resource files accordingly. See updated documentation for Script-Based Auth.

  • Version 1.0.7 (Mar 13, 2017)

    Requires: ZAP Standard 2.6.0 or newer.

     Warning: Not compatible with any ZAP 2.5.X release due to API changes.

    • (info) Update ZAP API client to version 1.1.1 as it allows to use newer versions of ZAP (>2.5.0). The new version of the API allows for use of the (new) methods that do not require to pass the key (already passed in the constructor of the ClientApi, which takes care to always send it).

  • Version 1.0.6 (Mar 13, 2017)

    • (error) Burned Release.

  • Version 1.0.5 (Nov 23, 2016)

    Notice: Last 2.5.X compatible release.

    • (error) Included extension of the script filename to the displayed script name.
    • (error) Fixed misnamed variables for PluginCallabe of ZAPDriver.java.

  • Version 1.0.4 (Nov 22, 2016)

    • (error) Set target java level to 1.7 rather than 1.8 in pom.xml.
    • (error) Use evaluatedContextName in Spider Scan API call.
    • (info) Update README to include required troubleshooting information.
    • (info) Added a release shield.

  • Version 1.0.3 (Nov 19, 2016)

    • (error) Fixed bad link in index.jelly for Plugin Manager (Installed and Updated).

  • Version 1.0.1 (Nov 18, 2016)

    • (info) New release (compiled with JDK 8 rather than JDK 7).

  • Version 1.0.0 (Nov 18, 2016)

    • (tick) Initial release
  • No labels