Child pages
  • HPE Application Automation Tools

Due to some maintenance issues, this service has been switched in read-only mode, you can find more information about the why

and how to migrate your plugin documentation in this blogpost

Skip to end of metadata
Go to start of metadata

 


New Wiki Page

Please click the following link to reach our new wiki page: https://wiki.jenkins.io/display/JENKINS/Micro+Focus+Application+Automation+Tools.

 

Link to Latest  Plugin 

Use the following link to get the latest version of the plugin: https://updates.jenkins.io/experimental/latest/hp-application-automation-tools-plugin.hpi.

 

 

 

  • No labels

22 Comments

  1. Unknown User (dancho80)

    H all,

    can I use this plugin just to read a Test Lab results? We have some manual tests that managed in QC, and for now, there is no option to display the results during the build in Jenkins.

  2. Unknown User (nairshij)

    Hi ,
    I am using HPE tools plugin to integrate the LR(Jenlin Slave) execution from Jenkins master.
    When we run the test, Jenkins is not able to launch the HpToolsLauncher.exe,please advise how to resolve the below error.

    Jenkin Version-2.89
    OS- Windows 2012 R2 Standard-64 bit
    .
    [CICD_Job_UV_PerfExec] $ C:\Jenkins\workspace\CICD_Job_UV_PerfExec\HpToolsLauncher.exe -paramfile props04122017235955970.txt
    Unknown error (0x2e4)
    ERROR: Failed running HpToolsLauncher java.io.IOException: Cannot run program "C:\Jenkins\workspace\CICD_Job_UV_PerfExec\HpToolsLauncher.exe" (in directory "C:\Jenkins\workspace\CICD_Job_UV_PerfExec"): CreateProcess error=740, The requested operation requires elevation
    Build step 'Execute HPE tests from file system' changed build result to FAILURE

    Thanks
    Shiju

  3. Unknown User (nairshij)

    Issues are resolved by disabling "run as administrator" for HPToolsLauncher.exe"

  4. Unknown User (djalanmaiden)

    Can this plugin work if my Jenkins is installed on Linux?

  5. Unknown User (mukeshdhingra)

    Hi

     

    I am getting below error while Integrating jenkins with PC 12.55 using the plug in HPE Application Automation Tools. Please let me know if any one of you have any idea.

     

    executeRequest exception: Exception of type 'HP.PC.API.Common.Exceptions.InvalidAuthenticationDataException' was thrown. Error code: 1100
    Login failed
    1. Unknown User (mukeshdhingra)

      Mine issue is drilled down and found that Lab access was also required to run the jenkins job for pc integration. As soon as added the lab admin access the job worked. Thanks for HPE (Microfocus) support team for drilling it down.

  6. Unknown User (gront)

    For any issues involving the plugin please open a ticket in our JIRA, so we could address this properly.

  7. Unknown User (davidgarratt)

    I am having difficulty getting the plugin to pick up the junit xml file.  I have tried a number of file locations and using wildcards allows it to pickup things like my build.xml.  Even if I put the junit.xml file in the same location as the build.xml, it is not picked up. I have checked the file permissions and all is ok.

    Are there any known issues here?

    Thanks


    Dave Garratt

  8. Unknown User (gront)

    Unknown User (davidgarratt), please use the link above and open a JIRA ticket, so we can handle your issue properly.

  9. Unknown User (felipelocatelli)


    Hello, the tests run upon reaching the timeOut are not saving the 'Test Result', how do I correct this problem?

     

  10. Unknown User (gront)

    Unknown User (felipelocatelli) please use the link above and open a JIRA ticket, so we can handle your issue properly.

  11. Unknown User (sunilkaveti)

    Hello can someone please help explain how this plugin works with performance center.

    And also is it possible to integrate SAP->Jenkins→Performance Center. basically once the Transports are moved Jenkins has to trigger the scenario in PC.

    Is this possible? Any success stories. Please help 

     

    Highly Appreciated your response !!!!

    Many Thanks,

    Sunil 

  12. Unknown User (gront)

    Unknown User (sunilkaveti) Have you tried looking at this? RunningPerformanceTestsusingPerformanceCenter

    To integrate Sap with Jenkins seems like something which is not connected to our plugin but in Jenkins itself.

  13. Unknown User (eric_lenz)

    We currently have an ALM session time limit of 30 minutes. When our test cases take longer than this, the plugin is disconnected. Is there a way to have the plugin refresh the connection every now and then?

    In the below scenario, the test case ran but after 30 minutes the HPToolsLauncher seems to have been logged out.  

    Unhandled Exception: System.NullReferenceException: Your Quality Center session has been disconnected. Contact your system administrator for more information
       at Mercury.TD.Client.Ota.QC9.ITSTest.get_LastRun()
       at HpToolsLauncher.AlmTestSetsRunner.GetTestRunId(ITSTest currentTest)
       at HpToolsLauncher.AlmTestSetsRunner.WriteTestRunSummary(ITSTest prevTest)
       at HpToolsLauncher.AlmTestSetsRunner.RunTestSet(String tsFolderName, String tsName, Double timeout, QcRunMode runMode, String runHost)
       at HpToolsLauncher.AlmTestSetsRunner.Run()
       at HpToolsLauncher.Launcher.RunTests(IAssetRunner runner, String resultsFile)
       at HpToolsLauncher.Launcher.Run()
       at HpToolsLauncher.Program.Main(String[] args)
    An error occured while disposing runner: Your Quality Center session has been disconnected. Contact your system administrator for more information.

     

    The ALM timeout setting seems to be for waiting for ALM, where in our case we need the connection to stay active.

  14. Unknown User (gront)

    Hey Unknown User (eric_lenz), It seems like a bug in ALM session, please file a JIRA issue, so we can handle this properly.

  15. Unknown User (3psilon)

    Hi, in Jenkins System Configuration, under "ALM Octane CI" section, the "Test Connection" is fine.

    But, inside a job main view, when I hit "HPE ALM Octane Pipelines" link in left menu (below Build Now), I'm getting "Connection to ALM Octane server failed"

    Any idea?

    Thanks

    1. Unknown User (mseldin)

      Hi , Did you save the configuration of ALM Octane CI ?

      1. Unknown User (3psilon)

        Yes sure!

        I'm wondering what are the API requests made in the first call and the second.

        I can make requests to Octane API from the server outside Jenkins using nodejs (authentication API and listing Octane workspaces).

        I'm behind a Proxy.

  16. Unknown User (sanyam42)

    I am getting below errror when integrating Jenkins with ALM using the plug in HPE Application Automation Tools. Please let me know if you have any idea to fix this

     

    [HPALM_RPA_TEST] $ C:\Jenkins\workspace\HPALM_RPA_TEST\HpToolsLauncher.exe -paramfile props30082018011552726.txt

    "Started..."
    Timeout is set to: -1
    Run mode is set to: RUN_LOCAL
    Error: folder cannot be found in ALM
    ================================================
    Run status: Job failed, total tests: 0, succeeded: 0, failures: 0, errors: 0

  17. Unknown User (gront)

    Unknown User (sanyam42)Unknown User (3psilon), Open a JIRA ticket with hp-application-automation-tools as a component and the label with the corresponding product.

  18. Unknown User (burekp)

    we recently upgraded the HPE Application automation tools plugin from from v5.2 to v5.4 and it's throwing the error below in the Jenkins log every 30 seconds:

    Sep 16, 2018 7:40:15 PM SEVERE com.hpe.application.automation.tools.octane.tests.AbstractSafeLoggingAsyncPeriodWork logError
    MQM Test Dispatcher thread failed with error
    java.lang.NullPointerException
    at com.hp.octane.integrations.services.tests.TestsServiceImpl.isTestsResultRelevant(TestsServiceImpl.java:89)
    at com.hpe.application.automation.tools.octane.tests.TestDispatcher.doExecute(TestDispatcher.java:127)
    at com.hpe.application.automation.tools.octane.tests.AbstractSafeLoggingAsyncPeriodWork.execute(AbstractSafeLoggingAsyncPeriodWork.java:55)
    at hudson.model.AsyncPeriodicWork$1.run(AsyncPeriodicWork.java:101)
    at java.lang.Thread.run(Thread.java:748)

    This was not happening in v5.2 and seems to be some type of scheduled process that is related to the Octane SDK.  We do not use the Octane SDK.  Is there a way we can remove this periodic execution?

  19. Unknown User (gront)

    Unknown User (burekp), Hey I am not aware of a way that you can disable Octane, it seems like a bug that might be solved in v5.5. Open a JIRA issue and Octane developers could advise you better.