Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Documented limitiation, requirement and dependeices for how to use the plugin.

...

Limitations, requirements and dependencies

  • The plugin only supports the Jenkins Freestyle project (not Maven or Multi-configuration aka. Matrix). In other project types than the Freestyle, the UI of Pretested Integration will not show up.
  • Git 1.9.x must be installed and available on the Jenkins build executor in command line. On Windows we depend on git commands to be available in the Windows command shell (not Git Bash, nor Cygwin).
  • Git configuration dependencies: the user account of the Jenkins build executor must be available to push to your integration repository. This typically means that you have to use either http- or ssh-credentials configured for the user account running the Jenkins slave.

Support and contact

Please send us an email on support@praqma.net if you have a request or question regarding the plugin.

...