Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 5.3
Note
titleDeprecated: This plugin has been removed from the Jenkins Update Centre

This is built in to Jenkins core as of version 1.416 — CAPTCHA support is now optional.
Archived versions of this plugin remain available for download.

Wiki Markup
{jenkins-plugin-info:pluginId=security-no-captcha}

Excerpt

Simply extends Jenkins' simple security to remove the CAPTCHA check.

Roadmap

Version 1.x

  • Probably should deprecate this plugin and roll into the core security, but I didn't want to try and touch the core since it's "security".
  • If this can't be rolled into the core security, then at least the core should be tweaked to be more extensible - e.g. make about 5 methods protected instead of private. The problem with that is then this plugin would depend on the very latest core, which is okay since Jenkins warns you not to upgrade.

Version 1.0 - Initial release