Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Note

If you are using Maven version earlier than 2.0.9, you'll need to follow additional steps.

Creating a New Plugin

Note

The last released version of the plugin archetype is somewhat out-of-date. If you have an up-to-date working copy of the Hudson source, you might want to run "mvn install" under hudson/tools/maven-hpi-plugin to get the latest and greatest.

To start a new plugin, run the following maven command:

...