Skip to end of metadata
Go to start of metadata

Plugin Information

View Jackson 2 API on the plugin site for more information.

Jackson 2 API Plugin

This plugin exposes the Jackson 2 API to other Jenkins plugins.

See FasterXML Jackson Databind GitHub repo for more information.

Version History

Version 2.9.8 (Dec 17, 2018)

  • Update Jackson libraries to 2.9.8.

Version 2.9.7.1 (Nov 5, 2018)

  • Non-beta release of Jackson 2.9.7 as the baseline version for Jackson 2.x.

Version 2.9.7.0-beta (Oct 8, 2018)

  • Update Jackson libraries to 2.9.7.

Version 2.8.11.3 (Jun 4, 2018)

Version 2.8.11.2 (May 14, 2018)

  • (plus) Update jackson-databind to 2.8.11.1

Version 2.8.11.1 (Feb 09, 2018)

  • (plus) Update Jackson libraries to 2.8.11

Version 2.8.10.1 (2017/12/13)

  • Update Jackson libraries to 2.8.10
  • Update Parent POM to 3.2 and cleanup the discovered issues

Version 2.8.7.0 (2017/10/9)

  • Update Jackson to 2.8.7
  • Update parent pom
  • Increase baseline Java version to Java 8
  • Increase baseline Jenkins version to 2.60

Version 2.7.3 (2016/3/22)

  • Update Jackson

Version 2.7.2 (2016/3/22)

  • Update Jackson

Version 2.7.1 (2016/3/22)

  • Update Jackson

Version 2.7.0 (2016/3/22)

  • Update Jackson

Version 2.6.5 (2016/3/22)

  • Update Jackson

Version 2.6.4 (2016/3/22)

  • Update Jackson

Version 2.6.3 (2016/3/22)

  • Update Jackson

Version 2.6.2 (2016/3/22)

  • Update Jackson

Version 2.6.1 (2016/3/22)

  • Update Jackson

Version 2.6.0 (2016/3/22)

  • Update Jackson

Version 2.5.5 (2016/3/22)

  • Update to parent POM 2.x
  • Also versions matching Jackson 2 versions: 2.6.0, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.6.5, 2.7.0, 2.7.1, 2.7.2, 2.7.3

Version 2.5.4 (2015/10/12)

  • Initial release
  • No labels

4 Comments

  1.  

     

    The version of Jackson supported should be upgraded to at least version 2.8.10 to address the issues mentioned here:

    https://github.com/FasterXML/jackson-databind/issues/1723

    More Info:

    http://www.securityfocus.com/bid/99623

  2. Actually, it should be upgraded to at least 2.9.4 according to CVE-2018-5968 here: https://www.cvedetails.com/cve/CVE-2018-5968/

  3. The `github-api` plugin needs version 2.9.x too to address this exception.

  4. Yeah it will be helpful if we can get jackson2-api which supports jackson-databind 2.9.4+ version