Child pages
  • HP Application Automation Tools
Skip to end of metadata
Go to start of metadata

 

New Wiki Page

Due to rebranding, we have changed the address of the wiki page.

Please click the following link to reach our new wiki page: https://wiki.jenkins.io/display/JENKINS/HPE+Application+Automation+Tools.

 

Link to Latest  Plugin 

Use the following link to get the latest version of the plugin: https://updates.jenkins.io/experimental/latest/hp-application-automation-tools-plugin.hpi.

 

55 Comments

  1. Wow I Think is great Tools and I want to testing this aplications.

  2. hi,

    This is a good plug-in. I will definitely start using this with UFT web/service testing.  It would also work for GUI testing a stable application with less frequent GUI changes.

    Using this would certainly achieve higher automation ROI as the developers also get use of automated tests; or it could be used effectively within iterations....probably the second week of an iteration :-)

    Cheers!

    Jonathan

  3. The JIRA link at the top of this page is to a component that does not exist....

    I'm getting the following error message even after installing the client on a Windows 7 machine. I get the same error if running under a service or thru the logged on user:

    "Could not create scheduler, please verify ALM client installation on run machine by downloading and in installing the add-in form: "

  4. I had same issue. I solved it by using the link that download all HP stuff.

    http://AlmServer:8080/qcbin/start_a.jsp?common=true

    1. Using this link also solved my problem thank-you.

  5. I am now facing another issue.

    When I add Post action: Publish HP tests results, I get a HTTP 500 with a blank screen.

    Do someone knows how to get more information on what is happening.

    I have two Jenkins installed (both 1.493) and it is working on one, but not on the other....

    Apart this problem, I managed to set everything up, including running on slave Windows box, and it works very nicely.

  6. Solution found : it was due to Jenkins running with JAVA 5. This plug-in requires Java 6.

  7. 05/03/2013 08:14:48 Running: 1Login
    05/03/2013 08:14:48 Running test: 1Login, Test id: 97836, Test instance id: 101042
    Test: 1Login, Id: 101042, Execution status: Running

    Test: 1Login, Id: 101042, Execution status: Passed, Message: Passed

    Step: Test iteration 1, Status: PassedException while reading step data: Object reference not set to an instance of an object.

    I am getting this exception , but test cases are passing. Can some one look into this

  8. Is there a way to parameterize the value placed in the "Testing Tool Host" edit control?

    I need to use a specified build parameter string to represent the IP address of the particular machine I want my Test Set to run against.

    I have tried multiple syntax permutations in an attempt to access the environment variable from the edit control, but am unable to get the environment "build parameter" to pass through to ALM.

    Thanks for any clue you may be able to provide!

  9. When I submit job with step "Execute HP tests from *", i receive 500 error:

    Exception: java.lang.RuntimeException: Failed to instantiate class com.hp.application.automation.tools.run.RunFromFileBuilder from {"stapler-class":"com.hp.application.automation.tools.run.RunFromFileBuilder","kind":"com.hp.application.automation.tools.run.RunFromFileBuilder"}

    Stacktrace:javax.servlet.ServletException: java.lang.RuntimeException: Failed to instantiate class com.hp.application.automation.tools.run.RunFromFileBuilder from {"stapler-class":"com.hp.application.automation.tools.run.RunFromFileBuilder","kind":"com.hp.application.automation.tools.run.RunFromFileBuilder"}

    at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:719)
    at org.kohsuke.stapler.Stapler.invoke(Stapler.java:770)
    at org.kohsuke.stapler.MetaClass$6.doDispatch(MetaClass.java:241)
    at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
    at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:677)
    at org.kohsuke.stapler.Stapler.invoke(Stapler.java:770)

    Server: Ubuntu 12.04 x64, tomcat6, OpenJDK 1.6.

    Help me please!

  10. Hey I have been using this tool with QTP and it has been great. I have not been able to find out however if I can pass in parameters to my QTP tests. Is this functional available though this plugin?

    1. Hi

      Nathaniel

      Can you please tell which ALM plugin or client you have install and Also do you need to install QTP software on same server

      Thx

      C

  11. When I setup "Execute HP Test From*" and save configruation I get error

    Also It does not give me any option to pick ALM server

    Please help

    Unknown macro: {"stapler-class"} ">Stack tracejavax.servlet.ServletException: java.lang.RuntimeException: Failed to instantiate class com.hp.application.automation.tools.run.RunFromAlmBuilder from
    Unknown macro: {"stapler-class"}

    at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:726)
    at org.kohsuke.stapler.Stapler.invoke(Stapler.java:777)
    at org.kohsuke.stapler.MetaClass$6.doDispatch(MetaClass.java:239)
    at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
    at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:684)
    at org.kohsuke.stapler.Stapler.invoke(Stapler.java:777)
    at org.kohsuke.stapler.Stapler.invoke(Stapler.java:586)
    at org.kohsuke.stapler.Stapler.service(Stapler.java:217)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:45)
    at winstone.ServletConfiguration.execute(ServletConfiguration.java:248)
    at winstone.RequestDispatcher.forward(RequestDispatcher.java:333)
    at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:376)
    at hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:96)
    at hudson.util.PluginServletFilter.doFilter(PluginServletFilter.java:88)
    at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
    at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
    at hudson.security.csrf.CrumbFilter.doFilter(CrumbFilter.java:48)
    at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
    at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:84)
    at hudson.security.UnwrapSecurityExceptionFilter.doFilter(UnwrapSecurityExceptionFilter.java:51)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
    at jenkins.security.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:118)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
    at org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
    at org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:142)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
    at org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:271)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
    at org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:174)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
    at jenkins.security.ApiTokenFilter.doFilter(ApiTokenFilter.java:64)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
    at org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249)
    at hudson.security.HttpSessionContextIntegrationFilter2.doFilter(HttpSessionContextIntegrationFilter2.java:67)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
    at hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:76)
    at hudson.security.HudsonFilter.doFilter(HudsonFilter.java:164)
    at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
    at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
    at org.kohsuke.stapler.compression.CompressionFilter.doFilter(CompressionFilter.java:47)
    at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
    at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
    at hudson.util.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:81)
    at winstone.FilterConfiguration.execute(FilterConfiguration.java:194)
    at winstone.RequestDispatcher.doFilter(RequestDispatcher.java:366)
    at winstone.RequestDispatcher.forward(RequestDispatcher.java:331)
    at winstone.RequestHandlerThread.processRequest(RequestHandlerThread.java:227)
    at winstone.RequestHandlerThread.run(RequestHandlerThread.java:150)
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

  12. Hello All,

    I am new user and we are currently automating Jenkins with QC which inturns linked with QTP scripts, I have configured my Jenkins as mentioned here in user guide using Configure the connection to your ALM server & Running Tests Sets from ALM sections.

    I am connecting to QC with credentials set by my QC administrator and then bridged QTP within QC with a test set under test_lab (Root\TestFolder\TestSet) and for your info QTP scripts are in different machine then Jenkins.

    I tried executing QTP scripts from QC it all works but when I try it from Jenkins am getting autorization error. Before someone asks, my credentials are correct and I verified manually

    Timeout is set to: 300
    Run mode is set to: RUN_REMOTE
    Failed to Login
    Error: Cannot Login to QC: Authorization failed
    Build step 'Execute HP tests from HP ALM' changed build result to FAILURE
    Finished: FAILURE

    Could you please help me what would be wrong here please?

    Thanks

  13. Hi,

    I have a question on this plugin. Does this plug in only allow triggering tests which are automated using HP automatin tool ?

  14. Hi All,

    Can we parametrize the Test set? So instead of using Root\testfolder1\testset_a in test set, I want to define a string parameter and use it. Can we do that?

    1. Did you find any solution for this ?

  15. r p

    Can someone please advise, when I attempt to use this plugin to run UFT tests from the filesystem I just keep getting the error "There are no valid tests to run!" What am I doing wrong?

  16. Hello,

    We are currently working on Integrating UFT scripts with Jenkins. There are some blind spots though:

    • Is there a way to print the Reporter object outcome in the Jenkins console (apart from just printing the result)?
    • Is there a way to use Jenkins build parameters with the "Execute tests from file system" option to be able to parametrize the build trigger?
    • Are there plans to update the tool with the above functionality and if so are there any estimates?

    Thank you in advance!

  17. Hello,

    I'm trying to execute UFT 12 tests. I have installed the latest plugin version.
    I am trying to execute the test with the "Execute HP tests from file system" option because I don't have an ALM.

    The plugin console shows the next error:

    Lanzada por el usuario madefg05
    Ejecutando remotamente en  ESCLAVO_VWD_PAUTOM01
    [SmartClient_PRUEBAS_UFT_2] $ 2/workspace/SmartClient_PRUEBAS_UFT_2/HpToolsLauncher.exe -paramfile props30072014143011685.txt
    "Started..."
    1 tests found:
    C:\UFT\04_CasosPrueba\Pruebas
    ============================================================================
    30/07/2014 14:30:11 Running: C:\UFT\04_CasosPrueba\Pruebas
    Error: Retrieving the COM class factory for component with CLSID

    Unknown macro: {29E73840-B66F-4930-9345-139090CD1D16}

    failed due to the following error: 80080005 Server execution failed (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)).\n   at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
       at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
       at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
       at System.Activator.CreateInstance(Type type, Boolean nonPublic)
       at System.Activator.CreateInstance(Type type)
       at HpToolsLauncher.GuiTestRunner.ExecuteQTPRun(TestRunResults testResults)
    Test result: Error
    30/07/2014 14:30:59 Test complete: C:\UFT\04_CasosPrueba\Pruebas
    -------------------------------------------------------------------------------------------------------
    ================================================
    Run status: Job failed, total tests: 1, succeeded: 0, failures: 0, errors: 1
    Error  : C:\UFT\04_CasosPrueba\Pruebas
    ================================================
    Report archiving mode is set to: ALWAYS_ARCHIVE_TEST_REPORT
    Sending e-mails to: xxxxxxxxxxxx@xxxxxxx
    Notifying upstream projects of job completion
    Finished: FAILURE

    I have tried to fix the problem changing the COM components configuration and Registry entries but it wasn't succeed.

    Does anybody know the cause of the problem or how to fix it?

    Thanks

  18. Hello,

    Since the integration requires the ALM Client, and that client is only available for Windows, is it not possible to integrate Jenkins on Linux with HP ALM Performance Center?

    Thanks!

  19. Hello

    I have latest HP automation tools installed which runs functional tests using the same job and the test sets passed as a parameter. I have publich HP results added to the post build action. and I am using the Running Test Sets from ALM option

    The trouble I am facing is my reports xml file are generated but not being published on jenkins. 

    I am running the slaves in a headless rather than windows service. Any one come across this type of issue. 

    Any help on this would be much appreciated. or anyone one if this kind of functionality is supported by the plugin

    Many thanks for your help.

    Regards

    Jay

  20. Did I miss something important? when I run the jenkins job,it show that:

    ******************************start********************************************

    "Started..."

    HP Automation Tools Command Line Executer

    Usage: HpToolsLauncher.exe  -paramfile <a file in key=value format> 

    -paramfile is required in for the program to run

    the parameter file may contain the following fields:

    runType=<Alm/FileSystem/LoadRunner>

    almServerUrl=http://<server>:<port>/qcbin

    almUserName=<user>

    almPassword=<password>

    almDomain=<domain>

    almProject=<project>

    almRunMode=<RUN_LOCAL/RUN_REMOTE/RUN_PLANNED_HOST>

    almTimeout=<-1>/<numberOfSeconds>

    almRunHost=<hostname>

    TestSet<number starting at 1>=<testSet>/<AlmFolder>

    Test<number starting at 1>=<testFolderPath>/<a Path ContainingTestFolders>/<mtbFilePath>

    * the last two fields may recur more than once with different index numbers

    *************************************end****************************************

    important

  21. Hello,

    A new test is opened while triggering the script from Jenkins. So the test script in the test set are not executing due to unsaved new test script. Please see the log and advise.

    14/04/2015 17:12:23 Running: 1ClaimEligibilityAndBenefit
    14/04/2015 17:12:23 Running test: 1ClaimEligibilityAndBenefit, Test id: 2933, Test instance id: 139582
    Test: 1ClaimEligibilityAndBenefit, Id: 139582, Execution status: Running
    Test: 1ClaimEligibilityAndBenefit, Id: 139582, Execution status: Unknown, Message: Unable to open the 'ClaimEligibilityAndBenefit' test.
    Test: 1ClaimEligibilityAndBenefit, Id: 139582, Execution status: Error, Message: Unable to open the 'ClaimEligibilityAndBenefit' test.
    14/04/2015 17:12:43 Test complete: 1ClaimEligibilityAndBenefit

  22. Hello,

    My Jenkins version is 1.609

    Can someone help me set it up?  I have just added the post build step to Publish HP results.  This is a new job which hasn't been run yet.

    The build step includes "Execute HP functional tests from HP ALM"

    As soon as I hit Apply, it throws this exception.  Any ideas?  

    Stack tracejavax.servlet.ServletException: java.lang.NoClassDefFoundError: hudson/tasks/test/TestResultProjectAction

    at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:796)
    at org.kohsuke.stapler.Stapler.invoke(Stapler.java:876)
    at org.kohsuke.stapler.MetaClass$6.doDispatch(MetaClass.java:249)
    at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
    at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:746)
    at org.kohsuke.stapler.Stapler.invoke(Stapler.java:876)
    at org.kohsuke.stapler.Stapler.invoke(Stapler.java:649)
    at org.kohsuke.stapler.Stapler.service(Stapler.java:238)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:686)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1494)
    at hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:123)
    at com.smartcodeltd.jenkinsci.plugin.assetbundler.filters.LessCSS.doFilter(LessCSS.java:46)
    at hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:120)
    at hudson.plugins.audit_trail.AuditTrailFilter.doFilter(AuditTrailFilter.java:95)
    at hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:120)
    at hudson.util.PluginServletFilter.doFilter(PluginServletFilter.java:114)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1482)
    at hudson.security.csrf.CrumbFilter.doFilter(CrumbFilter.java:48)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1482)
    at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:84)
    at hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:76)
    at hudson.security.HudsonFilter.doFilter(HudsonFilter.java:168)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1482)
    at org.kohsuke.stapler.compression.CompressionFilter.doFilter(CompressionFilter.java:49)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1482)
    at hudson.util.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:81)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1482)
    at org.kohsuke.stapler.DiagnosticThreadNameFilter.doFilter(DiagnosticThreadNameFilter.java:30)
    at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1474)
    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:499)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:533)
    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:428)
    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)
    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
    at org.eclipse.jetty.server.Server.handle(Server.java:370)
    at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:489)
    at org.eclipse.jetty.server.AbstractHttpConnection.content(AbstractHttpConnection.java:960)
    at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.content(AbstractHttpConnection.java:1021)
    at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:865)
    at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:240)
    at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
    at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:668)
    at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:52)
    at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:744)
    Caused by: java.lang.NoClassDefFoundError: hudson/tasks/test/TestResultProjectAction
    at com.hp.application.automation.tools.results.RunResultRecorder.getProjectAction(RunResultRecorder.java:361)
    at hudson.tasks.BuildStepCompatibilityLayer.getProjectActions(BuildStepCompatibilityLayer.java:93)
    at hudson.model.Project.createTransientActions(Project.java:249)
    at hudson.model.AbstractProject.updateTransientActions(AbstractProject.java:745)
    at hudson.model.AbstractProject.save(AbstractProject.java:304)
    at hudson.model.AbstractItem.setDisplayName(AbstractItem.java:168)
    at hudson.model.Job.doConfigSubmit(Job.java:1183)
    at hudson.model.AbstractProject.doConfigSubmit(AbstractProject.java:785)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:298)
    at org.kohsuke.stapler.Function.bindAndInvoke(Function.java:161)
    at org.kohsuke.stapler.Function.bindAndInvokeAndServeResponse(Function.java:96)
    at org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:121)
    at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:53)
    at org.kohsuke.stapler.Stapler.tryInvoke(Stapler.java:746)
    ... 52 more

  23. Hi, amazing plugin thank you. Would it be possible for you to add automatic emailing for the Test Set Execution summary? Possibly pulling the email list from what's stored on QC for the execution summary. I am currently using a script that does this.

  24. Hello,

    I am trying to find out a way where i can download the High_Level_Report.xls file from the performance center after my test is over to a local directory .
    Is there a way to specify  the additional artifacts like this  which i want to download  ?  

    Additionally , i also need to extract the Run-ID   and store it in a text file when my test triggers , as the Run-ID is dynamic  , how to get that during run-time  ?

    Thanks in Advance...

  25. Attempting to schedule an automated test set that is stored in ALM to run through Jenkins. Installed the plugin and followed the configurations mentioned above but the job fails on running HPToolsLanucher.exe. Any ideas? thanks in advance.

  26. Hello, 

    Sometimes when we run the jobs from Jenkins, we get this console messages like below, the tests won't run in the QC but the job returns success status. Why does this happen? Is there a way to fix this? any workarounds?

    04:01:12 "Started..."
    04:01:12 Timeout is set to: 1200
    04:01:12 Run mode is set to: RUN_PLANNED_HOST
    04:01:24 ============================================================================
    04:01:24 Starting test set execution
    04:01:24 Test set name: *******, Test set id: 1097
    04:01:27 "Number of tests in set: "4
    04:01:27 Test 1: 101 *** will run on host: ***
    04:01:27 Test 2: 102-*** will run on host: ***
    04:01:27 Test 3: 103 *** will run on host: ***
    04:01:27 Test 4: 104 *** will run on host: ***
    04:01:33 Problem while running TestSet: Exception from HRESULT: 0x80040458
    04:01:33 "Scheduler started at:30/09/2015 04:01:23
    04:01:33 -------------------------------------------------------------------------------------------------------
    04:01:33 Test set: *****, finished at 30/09/2015 04:01:23
    04:01:34 ================================================
    04:01:34 Run status: Job succeeded, total tests: 4, succeeded: 0, failures: 0, errors: 0
    04:01:34 Unknown:
    04:01:34 Unknown:
    04:01:34 Unknown:
    04:01:34 Unknown:
    04:01:34 ================================================
    04:01:36 Archiving artifacts
    04:01:37 Recording fingerprints
    04:01:43 No emails were triggered.
    04:01:43 Warning: this build has no associated authentication, so build permissions may be lacking, and downstream projects which cannot even be seen by an anonymous user will be silently skipped
    04:01:43 Finished: SUCCESS

    1. Hi Nikunj,

      Can you please tell me how did u avoid the above exception you posted.

      Rgds,

      Sana

       

  27. Hi all,

    Could you please help me with this issue?

    https://issues.jenkins-ci.org/browse/JENKINS-31617

    Regards,

    Suriya

  28. HI 

    I am trying to define the results path while running load runner tests through jenkins and seems like by default it creates the results as a randomly generated folder can anyone help me with that.

  29. I have need to pull the defects from HP Quality Center which has REST API exposed. And show those defects in the dashboard view, which will help to track the defects raised or fixed for each build.

    From this plugin documentation, i could see it does lot more things. But who do i get this plugin to fit my needs of showing the defects, please guide me.   

  30. Hi,

    If UFT/QTP is present in a VM,and to integrate Jenkins with QTP/UFT, do we need to login to the VM ?

  31. I am trying to post my TESTNG results to ALM and I am receiving the following error:

    Failed to create Entity:test-sets:parent-id=238name=Automation_Testsubtype-id=hp.qc.test-set.external

    Any idea what is wrong?

    1. Did you uses ALM 12.5x? Since te external test type comes up with these version

  32. Hi,

    can you may add some example for passing build parameters directly to the AUT Configuration preparation step? in last releases this was not possible

    Thanks

  33. Hi,

    We are facing an issue while running this plugin on a Slave machine when started as a service. Where as when the plugin started manually it works. Getting the following error and the build fails.

    Could not create schedule, please verify ALM Client installation on run machine by downloading and add in installing the add-in form.

    1. Hi
      Please open a ticket on our jira.

  34. Hi team,

    I have a couple of simple questions where I have not been able to find suitable answers yet.

    We use HP Application Automation tool to orchestrate functional tests executed in UFT. All is well, no issue found.

    My questions are:

    1- what is the true benefit in having the post-build action / Publish HP test result option enabled?

    2- when enabled, is the archive stored on the server running Jenkins (what is the path of the archive)?

    3- when enabled, is there a negative impact in having the build workspace deleted after the build is done?

    overall, I am trying to find out the true benefit and optimal running conditions of this post-build action.

    Many thanks in advance,

    Cheers, Fred

    1. Hi
      Please open a ticket on our jira.

  35. Dear all,

    I just used Jenkins to execute a test on HP performance center, after the test, I tried to open the test result from Jenkins but found that I could only see the “Summary” graph through the result link, when I click other graphs e.g. “Running vUsers”, “Average Transaction Response Time” from the navigation panel of right hand side, it did not work.   Did anyone hit this before? Can provide some suggestion on it? Looking forward for your help!  Thank you inadvance!

    Regards

    Kent

    1. Hi
      Please open a ticket on our jira.

  36. Hi All,

    I'm trying to use this plugin (Execute HP tests using HP ALM Lab Management) and I have the issue below:

    Failed to start TEST_SET ID: 2428, ALM Server URL: http://qualitycenter.srv.fr/qcbin/ (Exception: Server returned HTTP response code: 403 for URL: http://qualitycenter.srv.fr/qcbin/rest/domains/DOMAIN/projects/APPLI/test-sets/2428/startruntestset)

    It's seems an issue about ALM permissions, do you have any pre-requisites on ALM configuration side ?

    Thanks for your help.

    Regards, Brice.

  37. I am using Jenkins and the HPE ALM plug-in to run the QC test lab tests on multiple Windows workstations.  I had to disable the workstation FIPS security on the workstations so it would work. Is anyone using FIPS on the workstations?  I opened  [JIRA] (JENKINS-42356) HP Application Automation Tools error "This implementation is not part of the Windows but its being considered a enhancement. 

    Thanks,

    Marvin

  38. H all,

    can I use this plugin just to read a Test Lab results? We have some manual tests that managed in QC, and for now, there is no option to display the results during the build in Jenkins.

  39. Hi All,

     

    This is in context with 'Jenkins - Performance center 12.01 integration.  Encountered below issues, please let me know your suggestions to overcome these issues

    1. I tried to plot avg response time graph in jenkins by using 'Post build data' option in build section.  But no data has been plotted.  The test didnt fail either as i noticed 'pct_percentile_90_trt.csv' has not been created during build execution.  Followed exam same configurations specified in the documentation.

          2.  I have 5 transactions in my LoadRunner script, but the 'Test result trend' graph always shows the count as '1'.  I have defined SLA for all the transactions.  Even if 1 out of 5 transactions fails SLA, the count in graph drops to zero.

     

     

    Thanks,

    Dinesh Kumar

     

     

     

  40. Hi ,
    i am trying to execute the load test in performance center by using jenkins but unable to execute the load test , please find the console output below

    Started by user anonymous
    [EnvInject] - Loading node environment variables.
    Building in workspace C:\Program Files (x86)\Jenkins\workspace\Performance Center
    - - -
    Test description: Sample Load Test
    Validating parameters before run
    OK
    Trying to login
    [PCServer='http://cphpcq1.sw.sherwin.com', User='vsm754']
    Login succeeded

    Executing Load Test:
    ====================
    Test ID: 555
    Test Instance ID: 162
    Timeslot Duration: 0:30(h:mm)
    Post Run Action: Do Not Collate
    Use VUDS: true
    ====================

    Error: executeRequest exception: Operation failed. Error code: 1001
    Error: Run could not start!
    Logout succeeded
    Empty Results
    Result Status: UNSTABLE
    - - -
    Build step 'Execute performance test using Performance Center' changed build result to UNSTABLE
    Recording test results
    None of the test reports contained any result
    RunResultRecorder: didn't find any test results to record
    Finished: UNSTABLE
    performance center test id & Id details

     

     

    Please let me know if i'm missing any thing

    1. Issue is resolved because i select the option USE VUDS by un-check that issue is resolve

  41. How do I pass a parameter to say one of the test cases that I'm running for UFT.

    I'm running a test case and need to pass the environment name as a parameter from Jenkins. Is that possible??

    1. Hi Gabriel,

      The content on this page has moved to: https://wiki.jenkins.io/display/JENKINS/HPE+Application+Automation+Tools

      For details about running UFT tests with Jenkins, see the UFT Help Center page on this topic: UFT and Jenkins

  42. Hello can someone please help explain how this plugin works with performance center.

    Highly Appreciated your response !!!!

    Thanks,

    Sunil 

  43. And also is it possible to integrate SAP->Jenkins→Performance Center. basically once the Transports are moved Jenkins has to trigger the scenario in PC.

    Is this possible? Any success stories. Please help 

    Many Thanks

    Sunil 

  44. Hi Sunil,

    The content on this page has moved to: HPE Application Automation Tools

    The section "Running Performance Tests using Performance Center" on this page contains detailed information.