Skip to end of metadata
Go to start of metadata

EzWall Plugin

Plugin Information

View EzWall on the plugin site for more information.


Add a button to display a fullscreen buildwall on each view.

Configuration

Just activate the plugin and lick on the EzWall button on any view.

Poll interval is configurable through Jenkins configuration page in the EzWall section and modifiable in the settings view when the wall is displayed.

Screenshots




Changelog

0.3

  • Added option to change the flashing of builds to be more subtle
  • Fixed missing contentType header
  • Fixed issue where jobs would stick with part of the building flash effect applied

0.2

  • Gravatar support (optionnal)
  • Job number display (optionnal)
  • User name display (optionnal)
  • Better style (orange instable job, better blinking...)

0.1 (18 Feb, 2012)

  • First version
  • Display on all views
  • Configurable polling

4 Comments

  1. First of all, this is a really cool plugin -- great job!

    I have an enhancement request for this plugin.  If a Jenkins system has a lot of projects under a view, the ezwall plugin takes a while to load and causes some extra load on the Jenkins machine.  Can you add a configuration option to disable the EzWall link for specific views?  Ideally, we'd be able to configure which views shouldn't allow the EzWall link via Manage Jenkins -> Configure System -> EzWall.  For example, the 'All' view on our Jenkins system has >1000 projects, so we'd like to prevent users from being able to do the EzWall on the 'All' view.  It would be nice to be able to specify a list of views that should not allow the EzWall link.

    1. Started a fork with said functionality implemented. May need to modify pom.xml Jenkins version (currently has 1.622 in it), but it should work other than that. https://github.com/Slayer0248/ezwall-plugin

  2. Hi,

    I'm using .2 of this plugin.  Whenever I click on the EZ Wall link, the screen is completely blank.  I'm using Chrome.  No links, or anything.  What am I doing wrong?

  3. when i am using this plugin .  I got  Blank  page.   and  got this  error

    Failed to load resource: the server responded with a status of 404 (Not Found) http://10.14.14.224:8080/plugin/ezwall/css/Aristo/Aristo.css

    Failed to load resource: the server responded with a status of 404 (Not Found) http://10.14.14.224:8080/plugin/ezwall/css/ezwall.css
    Failed to load resource: the server responded with a status of 404 (Not Found) http://10.14.14.224:8080/plugin/ezwall/js/require.js

    I know the reason.     the main page  try to load js  from    http://xxx:8080/plugin/xxxxx/xxx.js .  but the real  address is      http://xxx:8080/jenkins/plugin/xxxxx/xxx.js .        the word  "jenkins"   is  missing

    please   fix this bug