Child pages
  • CloudBees Jenkins Enterprise
Skip to end of metadata
Go to start of metadata

Deprecated: This plugin has been removed from the Jenkins Update Centre

Please install CloudBees Jenkins Enterprise through CloudBees installer available on www.cloudbees.com

Plugin Information

No information for the plugin 'cloudbees-enterprise-plugins' is available. It may have been removed from distribution.

CloudBees Jenkins Enterprise plugin

This plugin converts an OSS installation to a CloudBees Jenkins Enterprise (CBJE) installation. CBJE has 20+ plugins that address issues in enterprise installations. Plugins include folders, validate merges, templates, roles-based access control, backup plugins and others (complete list). Additionally, you can use the HA component to make Jenkins highly available.
Note: As part of the installation process, you will require a valid license to use the CloudBees Jenkins Enterprise plugins. 

Installation/Uninstallation

Prerequisites

  • You must be running a sufficiently new version of Jenkins: either the current LTS release, or the newest available weekly build.
  • Your Jenkins installation must be able to download and install plugins from the OSS update centre.
    In other words, if you cannot use the plugin update center to install this plugin then it will not work.

Installation

This plugin can be installed without restart, but will require a restart to complete installation. 

  1. Install the CloudBees Jenkins Enterprise plugin.
  2. Install the plugin without restart.
  3. Once the plugin is installed, go to Manage Jenkins » Install CloudBees Jenkins Enterprise and select your preferred installation option. It will add the CloudBees proprietary update center to the list of update centers used by your Jenkins instance as well as the certificate used to validate that update center's certificate.
  4. When all the plugins have been downloaded, a Safe Restart will be triggered, or if the Servlet Container that your Jenkins instance is running in does not support safe restarts, a notice bar will be displayed to tell you to restart your Jenkins instance.
  5. When your Jenkins instance restarts, you will be asked to either Request an evaluation license or provide an Enterprise license. A valid license is a necessary condition for the CloudBees Jenkins Enterprise plugins.

    If you do not want to register your system with CloudBees there is an option for removing the CloudBees plugins that require a license for use.

    You click on the red delete icons to remove the license enforcement check or the license manager plugin. A restart will be required if you remove any of the license enforcement checks or the license manager plugin.
  6. Once you have completed the registration process your Jenkins instance will complete startup as normal. 

Uninstallation

To uninstall, simply disable or delete the CloudBees Jenkins Enterprise plugin and the CloudBees Jenkins Enterprise License Entitlement Check plugins. Once these plugins are disabled, all the CloudBees Jenkins Enterprise plugins will be disabled automatically, though it is better to remove them from your instance to improve startup performance.

Version History

Version 15.05.1 (Oct 19, 2015)

  • Removed monitoring plugin due to reported incompatibilities with the HA proxy WAR.

Version 15.05.0 (Jun 19, 2015)

  • Updated to CloudBees Jenkins Enterprise 15.05 (1.609.1.1).

Version 14.8.0 (Nov 05, 2014)

  • Added support for getting a license from CloudBees Jenkins Operations Center.

Version 14.7.0 (Sep 02, 2014)

Version 14.6.0 (Jun 18, 2014; BOTCHED)

  • Updated to align with the 1.554.2.2 release of CloudBees Jenkins Enterprise.

Version 14.2.0 (Feb 27, 2014)

  • Updated to required minimum version of Jenkins to 1.548 to align with current required minimum Jenkins of folders plugin available from the regular non-LTS Jenkins OSS update center.

Version 13.11.2 (Feb 27, 2014)

  • Updated to align with the 1.532.2.2 release of CloudBees Jenkins Enterprise.

Version 13.11.1 (Dec 5, 2013)

  • Update to align with the 1.532.1.2 release of CloudBees Jenkins Enterprise, ensuring that the CloudBees Jenkins Operations Center client plugins are using the minimum required versions.

Version 13.11.0 (Nov 28, 2013)

  • Update to align with the 13.11 version of CloudBees Jenkins Enterprise. All plugin versions will now be upgraded to same as in that version.
  • Minimum required version of Jenkins has been upped to 1.532

Version 13.5.0 (May 22, 2013)

  • Update to align with the 13.5 version of CloudBees Jenkins Enterprise. All plugin versions will now be upgraded to same as in that version. 
  • Minimum required version of Jenkins has been upped to 1.509 due to the upgrade to Fast Archiver 4.0

Version 12.11.1 (Apr 10, 2013)

  • Update to version 4.0 of the cloudbees-license plugin to resolve classloading conflicts with bouncycastle

Version 12.11 (Mar 28, 2013)

  • Initial release