Child pages
  • Bundled Plugins
Skip to end of metadata
Go to start of metadata

To find out which plugins are bundled with Jenkins, look in the WAR file for .hpi and .jpi files.
For example (v1.630).

% unzip -l jenkins.war | grep hpi
   164546  09-20-15 12:03   WEB-INF/plugins/script-security.hpi
   112483  09-20-15 12:03   WEB-INF/plugins/antisamy-markup-formatter.hpi
   949638  09-20-15 12:03   WEB-INF/plugins/windows-slaves.hpi
    64366  09-20-15 12:03   WEB-INF/plugins/ssh-slaves.hpi
    74973  09-20-15 12:03   WEB-INF/plugins/ssh-credentials.hpi
    38073  09-20-15 12:03   WEB-INF/plugins/javadoc.hpi
  1030550  09-20-15 12:03   WEB-INF/plugins/pam-auth.hpi
   929025  09-20-15 12:03   WEB-INF/plugins/cvs.hpi
    55546  09-20-15 12:03   WEB-INF/plugins/external-monitor-job.hpi
    50065  09-20-15 12:03   WEB-INF/plugins/translation.hpi
   128645  09-20-15 12:03   WEB-INF/plugins/mailer.hpi
   101895  09-20-15 12:03   WEB-INF/plugins/ldap.hpi
    90421  09-20-15 12:03   WEB-INF/plugins/ant.hpi
   331127  09-20-15 12:03   WEB-INF/plugins/junit.hpi
   238601  09-20-15 12:03   WEB-INF/plugins/matrix-project.hpi
 10805330  09-20-15 12:03   WEB-INF/plugins/maven-plugin.hpi
  4683101  09-20-15 12:03   WEB-INF/plugins/subversion.hpi
   406478  09-20-15 12:03   WEB-INF/plugins/credentials.hpi
    79681  09-20-15 12:03   WEB-INF/plugins/matrix-auth.hpi
  • No labels

5 Comments

  1. As of LTS release 1.480.2, the bundled plugins are:

    ant.hpi
    cvs.hpi
    external-monitor-job.hpi
    javadoc.hpi
    ldap.hpi
    maven-plugin.hpi
    pam-auth.hpi
    subversion.hpi
    translation.hpi

    1. And as of LTS release 1.509.2, they are:

      ant.hpi
      credentials.hpi
      cvs.hpi
      external-monitor-job.hpi
      javadoc.hpi
      ldap.hpi
      mailer.hpi
      maven-plugin.hpi
      pam-auth.hpi
      ssh-credentials.hpi
      ssh-slaves.hpi
      subversion.hpi
      translation.hpi

      1. And as of LTS release 1.565.1, they are:

        ant.hpi
        antisamy-markup-formatter.hpi
        credentials.hpi
        cvs.hpi
        external-monitor-job.hpi
        javadoc.hpi
        ldap.hpi
        mailer.hpi
        matrix-auth.hpi
        matrix-plugin.hpi
        maven-plugin.hpi
        pam-auth.hpi
        ssh-credentials.hpi
        ssh-slaves.hpi
        subversion.hpi
        translation.hpi
        windows-slaves.hpi

        I've found it's all too easy to upgrade plugins from the Update Center, inadvertently choose a bundled plugin (since they're not marked), and thus have it get pinned to that version (and no longer upgrade when Jenkins itself is upgraded), which is why I try to keep track of which ones are bundled.

        1. LTS 1.580.1 contains:

          ant.hpi
          antisamy-markup-formatter.hpi
          credentials.hpi
          cvs.hpi
          external-monitor-job.hpi
          javadoc.hpi
          junit.hpi (NEW)
          ldap.hpi
          mailer.hpi
          matrix-auth.hpi
          matrix-plugin.hpi
          maven-plugin.hpi
          pam-auth.hpi
          ssh-credentials.hpi
          ssh-slaves.hpi
          subversion.hpi
          translation.hpi
          windows-slaves.hpi

  2. Small script to extract which bundled plugins and their versions are found in the jenkins.war file:

    https://github.com/nvgoldin/jenkins-scripts/blob/master/plugins_discover.py

    example:
    > wget https://updates.jenkins-ci.org/download/war/2.16/jenkins.war
    > ./plugins_discover.py --jenkins_war jenkins.war

    script-security : 1.13
    antisamy-markup-formatter : 1.1
    windows-slaves : 1.0
    ssh-slaves : 1.9
    ssh-credentials : 1.10
    javadoc : 1.1
    pam-auth : 1.1
    cvs : 2.11
    external-monitor-job : 1.4
    translation : 1.10
    mailer : 1.11
    ldap : 1.11
    ant : 1.2
    junit : 1.2-beta-4
    matrix-project : 1.4.1
    maven-plugin : 2.7.1
    subversion : 1.54
    credentials : 1.18
    bouncycastle-api : 2.16.0
    matrix-auth : 1.1